Upstream Provider - Nationwide Network & Phone Outage

Incident Report for Precision IT

Resolved

The nationwide network outage has been resolved. Our upstream provider has confirmed that the root cause was a storm-related power failure, which led to technical issues impacting Fibre and NBN services.

A fix has been implemented, and services have remained stable since restoration. We will continue to monitor for any further issues, but at this stage, all services are operating as expected.

If you are still experiencing any connectivity issues, please reach out to our support team.
Posted Feb 11, 2025 - 07:30 AEDT

Update

Internet links have remained stable and online over the past 2.5 hours since the fix from our upstream provider.

No official root-cause has been identified from our upstream provider at this stage. We will keep this post updated when we hear more.
Posted Feb 10, 2025 - 23:12 AEDT

Monitoring

A fix has been implemented and we are monitoring the situation as internet links recover across the country.

No official root-cause has been identified from our upstream provider at this stage.

Updates to follow.
Posted Feb 10, 2025 - 19:26 AEDT

Update

We are continuing to investigate this issue.
Posted Feb 10, 2025 - 19:08 AEDT

Update

We are continuing to investigate this issue.
Posted Feb 10, 2025 - 18:57 AEDT

Investigating

We have been receiving reports of a major nationwide network outage with our upstream provider. This is impacting Fibre and NBN connections, as well as phone services nation-wide.

We are working with our upstream provider and treating this as a priority issue.

All Australian states and territories are currently affected.

Stand by for further updates.
Posted Feb 10, 2025 - 18:47 AEDT
This incident affected: Voice & Data (PConnect Data, PConnect Voice).