Service Degradation - Microsoft Teams

Incident Report for Precision IT

Resolved

Microsoft have now resolved this issue.
Please reach out to Precision IT if issues return.
Posted Feb 09, 2023 - 08:16 AEDT

Identified

Microsoft has announced that Teams is currently experiencing a worldwide issue that is impacting messaging, call failures, and chat presence delays for end-users.

Microsoft are currently investigating the cause of the issue.
Posted Feb 08, 2023 - 13:26 AEDT
This incident affected: Voice & Data (PConnect Voice) and Vendor Services (Microsoft 365).