Issues with Inbound / Outbound Calling

Incident Report for Precision IT

Resolved

Upstream carrier has advised that the issue should be resolved now.
Posted Jul 05, 2024 - 15:09 AEST

Investigating

Upstream carrier has reporting issues with inbound / outbound calling. Issue seems to be intermittent, and affecting random calls.

Upstream Engineering is investigating the issue currently.
Posted Jul 05, 2024 - 14:31 AEST
This incident affected: Voice & Data (PConnect Voice).