Citrix Golden Image update freeze

Incident Report for Precision IT

Resolved

Citrix have applied an update to their backend servers to resolve the issue. After internal testing we are seeing functionality return to normal.
Posted Jun 26, 2024 - 09:07 AEST

Identified

Citrix Support have identified an issue with their backend which is in turn causing a problem with Golden Image updates. Citrix DevOps are working to fix the issue with utmost urgency and will advise us one functionality has been restored.

This will not impact you from logging into your Citrix Apps and Desktops.
Posted Jun 21, 2024 - 15:23 AEST