Platform upgrade to Precision Watch has been aborted due to unforeseen hardware requirements, which will require additional preparation works.
Will delay upgrade for the moment, and notify of new upgrade schedule in the near future.
Posted Dec 14, 2022 - 00:39 AEDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 13, 2022 - 22:30 AEDT
Scheduled
We will be undergoing scheduled maintenance during this time to the Precision Watch Monitoring Platform.
The upgrade is estimated to take about 1-2 hours, depending on the speed of the upgrade process.
Precision Watch will be inaccessible during the upgrade. This includes all functions related to the platform - including remote access, service alerts, etc.
For any questions or concerns, please contact our Support Desk.
Posted Dec 07, 2022 - 18:01 AEDT
This scheduled maintenance affected: Precision Services (Precision Watch).