Azure Virtual Desktop (AVD) Connectivity Disruption

Incident Report for Precision IT

Resolved

Following further investigation and monitoring, Microsoft has confirmed this outage was listed across multiple Azure regions in their service acknowledgement.

We are continuing to engage with Microsoft to obtain further details regarding the root cause to ensure Precision IT customers are not left vulnerable to any repeat incidents. Our team will closely monitor ongoing correspondence on this matter and take appropriate action as required.
Posted Aug 20, 2025 - 15:11 AEST

Monitoring

Some organisations experienced issues connecting to Azure Virtual Desktop this morning due to a Microsoft platform incident affecting session host registration. The issue has now been resolved, all session hosts are healthy, and connectivity has been restored. Our team is monitoring closely.
Posted Aug 20, 2025 - 10:21 AEST
This incident affected: Vendor Services (Microsoft Azure).