Exchange Online - Some users' Email Messages May Be Delayed

Incident Report for Precision IT

Resolved

Microsoft has resolved this issue and email flow has returned to normal in the Australian region.
Posted May 22, 2025 - 21:04 AEST

Update

Microsoft Support has provided the below update as of 6:00pm AEST:

"As we continue our investigation to identify the root cause, we are focusing on analyzing messaging patterns to determine our next steps. In parallel, we are testing a potential mitigation action which may resolve the issue."

The next Microsoft update is scheduled for 9:00pm AEST.
Posted May 22, 2025 - 18:07 AEST

Identified

Microsoft have flagged a widescale impact to email delivery for Australian users who use Exchange Online.

This will cause email delivery delays for all users.

Microsoft Engineers are investigating.
Posted May 22, 2025 - 16:40 AEST
This incident affected: Vendor Services (Microsoft 365).